Updated file list not being updated with new version

Version 3.8.385
Protocol used:Google Drive
Windows 10 Pro

Before this version, when i did an update on Google Drive, i could force a refresh by right clicking in the folder and choosing refresh. This would show any updated files in Netdrive. With 3.8.385 the list will not refresh to update new files that have been updated or added.

I also went into the Advanced options of the drive and checked “Always retrieve file list from the server” and it gives the same result and doesn’t refresh the file list.

The only way i have been able to refresh the file list, is actually disconnecting the drive and reconnecting it.

We will check the issue and get back to you. Thanks for your feedback.

If you do not have the problem with 3.7 please downgrade to 3.7 because 3.8 is a beta version and it may have some instabilities.

Sorry for the inconveniene it caused.

1 Like

Will do, appreciate the update :smile:


Testing this with:
3.8.855 (build 855, BETA) - released 08/02/2019
Windows 10 Pro x64

  • Now you can force refreshing folder using context menu of Windows Explorer or macOS Finder.

I am still unable to get the folder to refresh as stated above using right click and refresh. I have tested this by adding new folders and files to the Team/Shared Drive in Google Drive through the web client and it will not show the new folder/files being added in Netdrive 3.

I’d like to add to this that with last beta version some folders appeared as empty. I downgraded to last non-beta version and this was corrected.

Do you use Google Drive?

Thanks for your feedback.

I am on version 3.8.866 with Google Drive and am having the same exact issue.

I have a shared drive shared between two accounts.
Account A creates a folder and uploads a file to the shared drive
Account B (owner of the shared drive) does not see that file or folder, even a week later. If I right click and use the contextual menu to trigger the new NetDrive Refresh then it shows up right away. It seems the native refresh that used to take place no longer occurs.

It would also be nice to set a “Minimum refresh interval” as well as restoring the previous refresh functionality (not sure what used to trigger it, whether it was changes in files or just timed).

Thank You

Until they re-implement the old file/folder refresh, i have had to use a script that will refresh the folder

create a script or .bat file that will run a refresh every so often. for my needs i have a auto task that runs every hour.

nd3cmd.exe refreshpath “Folder Path”

@foreversadman @WarlordScott @Knackster

Hello foreversadman, Knackster, WarlordScott?

Thank you for using NetDrive.

Could you send debug log files to figure out by PM after reproducing this issue to figure out what happened?

I failed to reproduce this issue on my environment.

It’s very wired thing.

The “Refresh” command is exactly same with auto refreshing.

If you send the debug log files after reproducing, It will be very very helpful to solve this issue.


I am seeing the exact same thing on my end.

I am on build 3.8.879

Checked the logs and I am seeing this error: GoogleDrive::GetFileList >> No more backoff

I sent you two sets of logs. Please let me know if you need more.

I will let you know after review the log files.

Thank you.

Hello jon-b14f

Could you send debug log files via P.M. to figure out what happened?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.


@jon-b14f @Knackster @WarlordScott @foreversadman

Hello all.

I found the cause of the problem.

This is caused by a limitation on the api limit.

To avoid this issue, register your own api key.

Refer to a following topic.

If the issue persists even though register your own api key, turn off “GetChanges” option in “OPTION” of the drive item configuration.


Thank you for looking into this for us.

I already have registered secrets in my NetDrive account for each of my mounted Google Drives.
This was all working without issue before a recent update.

If this was caused by the API limit, wouldn’t it also fail when we tried to manually refresh the directory?

I would like to avoid turning off “Receive changes to files from server” as this is a great feature
Anything else we could try?

Thank you for your time and diligence in helping us.

If “Receive changes to files from server” is on, it calls the API every 5 seconds for changes.
This is the cause of the API limit.

If you’re using Google Drive alone, we recommend turning it off because it’s meaningless to get server-side changes.


I apologize for the delay, due to my line of work, i have been prepping for the hurricane.

As to what @Knackster said, if this is an API limit issue, how come the issue doesn’t come up when manually doing a refresh either by context menu or command line. If this was an API limit, would it be blocked both auto and manually?

Also just to add, i am using my own API key =)

Once things settle down here, i will work on getting you the logs you requested.

1 Like

I totally agree with you and would also echo your questions.

@WarlordScott, @Knackster

Please update NetDrive. We released a new version which includes fixes for the issue.

1 Like

Will update now, will we still need to turn off the “Receive changes to files from server” option?