Problem webdav Synology

Hello everybody.
Sice many months (years) i used Netdrive for Webdav conexion to my Diskstation.
Few days ago it doesn´t work. The configuration is exactly the same. It says: CONNECTION ERROR
I tried with external IP too without success.

I have no idea where the problem is

Hello dolfoss

Thank you for using NetDrive.

Could you attach debug log files to figure out what happened?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Or the following topic will be helpful.



I have exactly the same problem with my NetDrive (2.6.20 build 985).
From one day to the next, it doesn’t work anymore: ‘Connection error’.

I have changed nothing, either on the computer, the DiskStation nor the network.
Even on my desktop in the same network with the same items in the Options it works still without any problems.

I wanted also, as described above, produce a logfile. But in the Options I can only change the Log Level from ERROR to DEBUG, but there’s no VERBOSE.
So no logfile is generated.

In the synology DS I have nothing blocked.

What can I do to reuse Netdrive?

Regards Ivo


Are you using NetDrive2? As you know NetDrive2 is different with NetDrive3, there is no VERBOSE log level.

Unfortunately, the technical support of NetDrive2 is discontinued because the period of support is for 1 year.

But I think NetDriev2 works well with webdav on Synology NAS.

If you are using dynamic dns(ddns), please check your dns server.


Yes, I use NetDrive2.

What do you mean with check the dns server?

I have the problem only with the notebook. With the desktop in the same network it works still.

Regards Ivo

Yes, could you check dns server setting on your labtop?

I think it’s the issue of the network environment.


Thank you very much!
As I want to check the dns server settings, I saw that the laptop was connected to the guest-account (instead the “full” one) on my WLAN.

The laptop desided to change the account by itself :wink:

Now it works as before and I’m happy. Thank you for your help!

It’s a good news!

If you have any question, don’t hesitate to contact us.