WEBDAV: Windows 10 - Synology - "Permission Error" After Windows Updates

Has anyone else had this issue lately?

It’s always worked until Windows 10 ran some upgrades.
It still works on clients running Windows 7.
Even after updating both OS’s, Windows 7 still connects to the Synology running Webdav, however the machine running Windows 10 simply states “Permission Error” when trying to connect.

Both machines using the same login and password.
Can connect from both Netdrive 2 and 3 but only on the Windows 7 machines.

No firewall or anti virus blocking anything.
No strict security policy on the machine that sticks out.
Ive tried both 5005 and 5006 (SSL) and again, both work on W7 but neither on W10.
Tried running the program as Admin.

Any idea?
Anyone else run into this vague “permission error”.
Happens to all logins (admin, user, etc…)

Hello, following up. Anyone?

Hi maka.

Could you send me debug log files of both machines to figure out what problem is?
After setting the log level to DEBUG, please reproduce the problem.


Thank you.

I already sent log file, and replied

but there is no solution

So I can’t use netdrive after then.

You guys have to know many people can’t use netdrive because of this problem.

Dear zerowns and maka

Thank you for using NetDrive

I’m afraid that the account “Permission Error” occured don’t have permission to access.
You can set the permissionof “WebDAV Server” from the “Users” in control panel of Synology NAS DSM.

@zerowns @maka

Where did you send the log file?
I’m sorry about I couldn’t find the file.

Could you send me it again please?

I can access it from a Windows 7 computer using the same credentials, so I don’t believe it’s a setting on the SAN.

I am still trying to get the debug information for you. I have to use someone else’s machine (the user with the problem). Then I can send it.

Thank you for the help.

I installed the program (Netdrive 3) on another Windows 10 machine and it works.
Just this specific Windows 10 gives me permissions errors when i try to connect. I know it’s not that because it seems like Netdrive3 is web based so it technically carries the settings over from one machine to the next just by logging in. Here are the debug files. Any ideas?

No firewalls. Anti Virus turned off.


Dear maka

In the debug files, all I found is “HTTP/1.1 401 Authorization Required”.

In the past, there was a customer whose ip is registered in block list of the Synology NAS DSM.
Could you check your DSM’s block list?

Best regards.

That worked!!!
Thanks for the help.

1 Like