Google drive and netdrive "empty folder"

I have a problem with netdrive 3 and google drive. When I enter a folder that contains a large number of files, Windows 10 Explorer takes a while to open it and then launches the “empty folder” message. If I enter directly with google drive I can see all my files without problem.

This didn’t happen to me before and I don’t know how to fix it.

I have tried with different computers and I have disabled windows 10 browser “windows search” with the same result : “empty folder”

1 Like

This is exactly what happened to me as I reported in the ‘111028’ thread.

At least two folders appear as empty, both with a large number of files (1500 and 2500).

Hello bertarada

Could you attach debug log files to figure out what happened?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.


Hello bertarada

Please refer to a following topic.


I have same problem since I update netdrive3 yesterday.
I try API method in this forum, but there is no change.
I hope this problem will be solved ASAP.

1 Like

Hello, I just installed version 3.8.888 and it seems like the empty folder problem is solved. Thanks.

I was on 3.8.888 (with API key config) and huge folders were empty. For me, last usable version is 3.7.687.

@howmath @michal

Hello howmath, michal

Please register your own Google API Key and try with turn off “Receive changes to files from server”.


Hello. with the new version 888 it works correctly. The problem is solved, sometimes not at first but if you insist in the end it works. Thanks everyone for your help

The problem isn’t solved if it works “sometimes” and You should “insist”.

You’re right. In addition I just checked that when you add new files it does not update them. You have to disconnect the disk and reconnect it and then the new files appear.

Hopefully the netdrive technicians will solve it soon because that way you can’t use the application.

The problem is NOT solved just patched.

I updated to version 3.8.900 and I have the empty folders problem again and now every previous version has the same issue, even the one that was working for me now it doesn’t :frowning:

same issue. all previous versions have same issue nd3svc.log|attachment (713.0 KB) now.

Anyone come up with any solutions?

Having the same issue. Sometimes Netdrive refuses to connect to my Google Drive. When it does it says folders with a lot of files are empty. So far 3.8.879, 3.8.888 and 3.8.900 don’t work correctly. I don’t have an older version to try.

My file server is now useless!!!

You can download an older version from the site.

After correctly setting up my own api the problem seems to be solved.

1 Like

I have registered my own api key and I’m on the lastest Netdrive3 version but I still get the empty folders.

But a couple days ago, I don’t know how, the folders showed normally. I don’t know how this happened, I left my PC then came back after a while and found one of the folders showing the files. I might have left the folder refreshing while I was AFK, I’m not sure but it might be, because I tried refreshing many times.

But I had to restart my PC, and then the problem was there again. Empty folders…

This is really annoying since I have a Plex server I can’t use due to this issue!

1 Like

Did you create a new item after registering your api key?

Hello, I just installed version 3.8.888 and it seems like the empty folder problem is solved. Thanks.

Unfortunately not as I am still having the same problem with 3.8.915 and it is becoming very annoying as I have the data linked to other apps and it keeps coming back as an error and wiping all of the information attached!!

Can you please clarify what you mean by this? Do you mean that I need to delete my existing connection and create a whole new one from scratch?