Ftp folder show date and time on subfolders (as local unit "R")

i’m having this trouble with NetDrive. I use NetDrive as FTP connectro to local unit on Windows Server 2019 Standard (VM). I correctly connect to remote Drive but when i browse the remote folder i see that every subfolder name has beofre a date or a time stamp, like this:

if i do the same thing looking on the ftp site with filezilla i don’t see the year name or the time. This last way is the right one!

Can you help me to find out the way to let the time/year before the fodler’s name to be erased?

Same problem here. At our site it appears just after the latest update when accessing cloud storage via SFTP. Version is 3.8.888 (when checking about it says it was released at 08/29/2019). We’ve installed at 2019/30/08, your posting was also sent at 2019/30/08 so I think this is a new bug which makes netdrive unusable without any fix or working work-around via (S)FTP. :frowning:

@e317-info, @m-schneider

Thanks for your feedback. We will check and release a quick fix.

@e317-info, @m-schneider

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.

wich one of the log do i have to send to you?
i see several log files, but which is the particular one do you need??

Thank you

i attacch the nd3svc_FTP log in a compressed filenetdrive_log.zip (1.5 KB)

I’ve also sent you the asked logfiles and additionally attached further screenshots of the folder/files I was trying to click to or access to while VERBOSE logging.

Hello, attached to this mail you’ll find the asked VERBOSE logfiles as ZIP archive. I’ve also attached screenshots in chronological order as I was clicking in explorer while VERBOSE logging. You can clearly see, that NETDRIVE3 now since the update append the date and/or time of a file or a folder to the filename/foldername which results in access errors. For example the folder displayed as “2008 $temp” is really named as “$temp” on the SFTP server connected. The misbehaviour appeared directly after the last update at August 30 / August 31.

Kind regards, Michaela.

nd3log_supportissue_20190901_20190902.zip (44 KB)

@e317-info @m-schneider

Hello customers.

Thank you for using NetDrive.

I found a problem with incorrectly parsing a list of files from the log you sent.

I will fix this issue as soon as possible and let you check it.



Hello Michaela.

The cause is an incorrect parsing of the file list.
For example, the server responds with the following.

drwxr-xr-x 6 1000 1100 10 Apr 6 2017 Art; 1491508234

Previously, the server would have responded with a user account rather than 1000 or 1100.
This is because NetDrive recognizes 1000 and 1100 as file sizes.
We will fix this problem.

I think you use HiDrive.
If you are in a hurry, why not try HiDrive’s WebDAV connection?

Hello e317-info

I got the file you attached.

There is no file list datas in you log file but I guess your issue is a same thing with m-schneider’s

If you can contact admin of your server, fix user account to show account name in directory list.


drwxr-xr-x 2 1000 1100 2 Sep 1 2018 Camera Upload
drwxr-xr-x 2 account account 2 Sep 1 2018 Camera Upload

Then your issue will be solved.

Of course, NetDrive will also be fixed for this issues.


@e317-info @m-schneider

Hello customers.

Your issue is fixed.

Could you check your issue with a following url version?



is there any way to update without rebooting? i have netdrive on a windows 2019 production server and i cannot reboot anytime i need…

Thank you.

i updateted the version to the latest as you told me, but it fixed partially my problem. Some folders do not show date anymore (good!), some others show date before folder name.
You can have a look at the screenshot:

I attacch also the log file:

nd3svc_FTP.log (1.4 MB)

Wait for news as soon as possible. It is impossible to me to use my managment software with this problems!!

Thank you!

1 Like

Hello, same here. First I updated to the link postet here which resulted in Version 3.8.898 and rebooted. Then I’ve got the same result as @e317-info . Some folder were correctly displayed, some not with the year of the file date attached again.

But wait for this: after reboot I’ve got the message, that again a new version is avaiable 3.8.900. First I waited unsure if the previous fixed worked and I skipped this update to see the result. After realizing, that the patch link posted doesn’t solve the problem I manually updated by downloading from the website www.netdrive.net/download. After installation and reboot I’ve got 3.8.900 now.

Look at this result: now the drive is displayed as empty although connected to the SFTP server with FileZilla everything is fine. As a paying customer the promised SFTP function is essential for me. WebDav is not really an option as we need exact file date time recording when copying files between cloud and local storage which is correctly provided via SFTP & the Strato HiDrive service. Additionally SFTP is needed due security issues.

I don’t want to blame support, but why is this not tested before publishing such buggy versions at your site / or even in beta phase? Meanwhile other customers and users are also posting the same problem in the support forum:

Thank you for the previous attempts to analyze and solve the problem, but this seems to be not the right thing to fix it at all.

To solve the problem I would urgently suggest to publish a fix as soon as possible or to provide a documented and understandable downgrade method to a previous version of Netdrive which works properly with SFTP.

Looking forward to hearing from you.

Kind regards, Michaela.

P.S.: I’ll attache further screenshots and VERBOSE log as soon as possible.

Confusing: after Netdrive (which was freshly started after reboot directly after the last update to 3.8.900) failed due resulting in an empty folder I just closed the app and started in again. Now I’ve got the same result as in 3.8.898 but even more confusing: folders with year or time as prefix are mixed with folders correctly displayed


Attached you’ll find now my latest logfiles…nd3log_supportissue_20190901_20190906.zip (90.0 KB)

Please fix the problem! it is bnot possible to work like this!

1 Like

It is unacceptable that the program hasn‘t been working for a week. It is weekend again, and there is no update or reply from anyone. Frustration is starting to rise. After all, we are paying customers. It has been days since the 1st time we informed.