"Shared with me" Files Not Move Using NetDrive3

I have a question about the combination of NetDrive3 and OneDrive for business.
I am in trouble that I can not move files in the shared folder of OneDrive to
another folder in the same hierarchy.

Of the files in OneDrive for business assigned as a network drive, even if I try
to move a file in “Shared with me” to another folder, the file will not move.
All I can not do is move, copy & paste or delete of the file works correctly.

Files in “My Drive” can be moved or deleted.

The operation is done from Explorer of Windows, but it looks like it has been
moved normally for a moment, but when I press F5 to reload, it seems like the
file has been restored again. Of course, the file has not been moved to the
intended destination.

It is possible to move files using a browser such as Google Chrome or Internet
Also, if I mount OneDrive as a network drive with webdav without NetDrive3, the
files can be moved successfully.

At first I wondered if the shared file does not have my access, but as mentioned
above, I can move the file normally with methods other than NetDrive 3, so I
think the problem might be other than the access.

if you have any of these solutions, I’m glad if you can show me how.

I will get back to you after some tests.

I hoped this update would improve this issue, but after the update, “Shared with me” disappeared and became more serious.

For the OneDrive for Business we are working on adopting Microsoft Graph API. When it’s ready we will send you an working beta version.

Sorry for the inconvenience it caused.

1 Like


Please use following beta version. This version uses new APIs provided by Microsoft. We will continue to test with this API and with some initial test it seems ok to share with.



Thank you for the beta version.
I tried the program I received, but unsatisfactorily, the “Shared with me” folder remains invisible so its behavior seems to be the same as ver.3.8.888.
Therefore, it is not possible to test whether a file on OneDrive for business can be moved to another folder.

Can you send us debug log file to inspect the issue?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.

nd3log.zip (4.3 MB)

Thank you for the instructions.
I attatched log files.

Thanks for the log file.

From the log file I found that the file request is made by old API not Graph API.

I forgot to tell you that you need to create a new drive item using the plus button.

You need to select OneDrive for Business (Graph API) as Storage Type.


I’m sorry I didn’t notice it.
After retesting with the Gragh API selected, “shared with me” is displayed and the shared file is accessible again.
However, when trying to move the file to another folder, an error message was displayed and the file could not be moved.
I send a popup error display and log files. Since the pop-up error is in Japanese, it is written in English in red.

nd3log_capture.zip (10.6 MB)

The OneDrive for Business server returned following error message:


    "error": {
        "code": "accessDenied",
        "message": "The caller does not have permission to perform the action.",
        "innerError": {
            "request-id": "fad3e3a4-620b-42ad-9943-17354a2b9d03",
            "date": "2019-09-03T05:39:25"

It seems that your account does not have necessary permission to move the file.

nd3log.zip (24.0 MB)

Thank you for investigating logs.

After my some testing, I found a way to move the file. However, it is temporary and after a few minutes it will not be able to move again.
Could you give me some advice?

The method I tried is as follows.
Open three places in Explorer.
#1. Open a folder in “shared with me” (Destination)(with NetDrive3)
#2. Open another folder of “shared with me” that contains the file I want to move (source)(with NetDrive3)
#3. Open the same location as above 2 in a way that does not use NetDrive3. (source)(without NetDrive3)

Move files in the following order.
-Move the file from 2 to 1 -> result in, yesterday’s popup error
-Move the file from 3 to 1 -> result in, the windows security pop-up window appeared and I could move the file after clicking OK to close it.
-Move the file from 2 to 1 again. — result in, the file can be moved successfully.

However, after a while (approximately 10 minutes later), yesterday’s popup appeared and I could not move the file until I pressed OK in the above windows security popup window whitch says “these files might be harmful to your computer”.

In this case, if I register to a trusted site in the Internet option settings, it should not come out, but how do I register the destination address?( What is the address of “shared with me”?)

This windows security pop-up window may be the reason why files cannot be moved using NetDrive3.

The list registered in my trusted site is as follows.
https: //*.sharepoint.com
https: // (our-name) -files.sharepoint.com
https: // (our-name) -myfiles.sharepoint.com

How to open # 3 without using NetDrive3:
-Register the above to a trusted site.
-Set WebClient service to auto start
-Allocate a network drive.
Location: https: // -my.sharepoint.com/personal/

Thank you for your test. I added comments below each quote.

Before commenting each operation I want to make it sure that you cannot move files between separately shared folders. Files can only be moved inside a shared folder. If you want to move files between separetely shared folders we need to copy and paste the file then remove source file.

The move operation happens on server using Move API and it returned permission error. The permission error message in my previous message.

The move operation is actually copy and delete operation which happens on your PC. It is because that Windows determines that #1 and #3 is a separate and not related remote storages. Windows Explorer downloads the file from #3 and then it uploads the file to #1. If the copy operation is successful Windows Explorer will remove the file from #3. The security warning popup windows is displayed because the file is downloaded to your PC before uploading.

I’m not sure why this operation succeeded. It may be the result of NetDrive founding that the target file exists and the source file does not exists.

I think it is not possible to register the destination address as a trusted site because the drive is mounted using NetDrive and it does not have remote URLs.

Thank you for the easy to understand explanation.

I understand that I cannot move a file between shared folders with separate.
Certainly, I can move within the same shared folder, so we will change the way that we share our folders.

Thank you for your investigation and response.

1 Like

Thanks for using NetDrive.