.pdf file is listed as a folder

NetDrive version: 3.8.915
Windows/Mac Version: Win7-1 and Win10-1903

Hi.
We have been using the old NetDrive 1 on a Win7 computer for a long time to access a NAS via WebDav. And it has been working flawlessly.

Recently we got a Win10 computer and installed the old NetDrive 1 on it, but got bluescreens on it. So today we bought two licenses to the newest version of NetDrive and installed it.

However there are a couple of big issues with it. These issues appear both on the Win7 machine as well as the Win10 machine.

1. Some folders appear as files. And some files as folders!
For example, we have a file called “Kalender 2019.pdf”. It appears with a yellow folder icon! And when we click it, we get an error message that it’s inaccessible.
I tried removing the file extention, naming the file to “Kalender 2019” and it appeared as a file. I then renamed it back to “Kalender 2019.pdf” which gave it the correct icon and I was able to open it. I then closed the folder and reopened it, and voila, it’s back to being listed as a folder again!

2. Any file or folder with local characters will not show.
In Norway we have the characters “æ” (ae-combo), “ø” (slashed o), “å” (ringed a). Any file or folder with any of those characters do not show up at all in File Explorer. In a folder with 20 items, 7 items were missing because of these characters.
When I tried to rename any of these files to something without these characters (by using an older NerDrive) they turned up in NetDrive 3 again.

I have used the following technical setup:
Storage Type: WebDAV
Server: xxx.xxx.xxx.xxx:50000
Folder: xxxxx
Mount: T as Network Drive
I also tried to mount T: as local storage with the same result.

Is there a regional setting or something that I have missed?

Hello customer.

Could you attach debug log files to figure out what happened?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.

Regards.

I have attached 2 log files.
nd3log (1): This is with the drive attached as a local storage.
After attaching, I opened the drive. The same problems as yesterday, not showing many of the folders and files (those with local characters) and some files are shown as folders and folders as files.
I also tried a couple of things, I don’t know if it will show in the log:
1, I tried to make a new .txt file on the attached drive. That went ok.
2, I tried to rename it to something with local characters. Surprisingly that also went ok. So for some reason Netdrive3 will not show files or folders that originally have those characters, but has no problem with new files.
3, I then tried the renaming procedure on the .pdf-file to turn it from a folder type to a pdf-document type as described in my first post. It went like yesterday.

nd3log (2):
This is with the drive attached as a network drive.
With this attached I did the procedure described in point 3 above.

nd3log (2).zip (212.3 KB) nd3log (1).zip (126.5 KB)

Here’s a compilation of screenshots from both NetDrive 1 and 3
You may need to rightclick and “Show Image”.

Hello

I got the files you attached.

I will feedback after review.

Regards.

Hello runarpunar

I found that there are non-utf8 file names in the folder.

If you turn on “Attempt converting non-utf-8 files to UTF-8” option, your issue will be solved.

In a drive configuration, press “OPTION” button.

Then, check “Attempt converting non-UTF-8 files to UTF-8”.

Regards.