NetDrive /OSX hangs on start - not responding

After installing netdrive on MacOS, launched the NetDrive for the first time. I tried to access Google Drive, and it hangs. From that point, the application hangs after launch. Shows the splash screen and NetDrive goes unresponsive.

1/ I tried uninstalling and reinstalling, same result. Nothing happens on launch, and it goes into not responding. Had to Force Quit. Can’t give you a log since the app doesn’t open to give you the option to create a log.

2/ how do I do a clean uninstall that clears out all fo the initial settings

3/ why isn’t it working? I’m only using Google drive, and would like to mount the drive.



Nevermind… did several reboots and finally managed to get it to work. I have no idea why it didn’t the first time. Thanks!


If you are using Google Drive, I recommend to register your own API and secret key.

Please refer to the following topic.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.