Netdrive file lock service not available

Dear Netdrive technical support,

netdrive file lock service not available, the error message suddenly shown in my bottom of the folder, can you help to check what is the problem

Best Regards,
Huang Bo


Please check if you can open following page on machine where NetDrive installed.

Dear ysh,

the page I open shows

It works!

Best Regards,

Huang Bo

Same issue here after Update from v3.8.987 to v3.9.1160. I have installed this tool on 3 clients and the error only occurs on the client which has been updated to v3.9.1160.

On that client, I can open the page (“It works!”) but the message “NetDrive File Lock Service is not available!” remains.

@magichuangbo @kanz

Hello customers.

Thank you for using NetDrive.

Does your issue persists?

I guess the issue is solved now.

If you issue persists, please let me know.

Stay healthy.


No, same error here

and here too

Hello @jami @josef-e14f

Thank you for using NetDrive.

Where did you see the message? In explorer or trayicon?

The message will be shown when your pc cannot reach to our file lock server.

Even if the message appears, NetDrive works well except of file lock service.

If your issue persists, I think it’s better to have a remote session via AnyDesk.

If you want, please give me a private message.


HI @jyyoon,

I see the message at the trayicon. And the error persists since several days.


Hello @josef-e14f

I will send you a private message.



I use NetDrive everyday. It’s been nagging me to update to 3.9.1190, but I was unable to restart due to work files being open so I had to delay the update for a couple of days. I just completed it, and upon restart I’m seeing a little red dot overlaid on the NetDrive icon in my Windows 10 task bar. Hovering over it displays the message:

NetDrive3 - NetDrive File Lock Service is not available!

I came here and see others also having this issue. I did go to and see:

It Works!

I don’t see a fix posted by NetDrive Support here. What does this message mean, and when will it be fixed?


Can you send us debug log files? I think we need to check the log files first.

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Sorry for the inconvenience it may caused.

@ysh Just sent you my logfiles as you requested. I have NetDrive running on 2 devices and the issue is the same on both of them.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.