NetDrive 3.0 Mounting

I for now bought 1 private license to test your system for my company, where I will need at least 10 licenses.

I installed and configured the NetDrive 3.0 on a Microsoft Surface with Windows 10 (up to date). Then I added some virtual drives through connection with my QNAP NAS. So far everything worked fine and I can browse the virtual drives, download and work on the files from the NAS.

Now to my problems:

  1. Edited files are not uploaded again and I don’t know the source of the problem.
  2. Best solution would be to work on the files directly. SFTP works fine for the NAS-Server structure, but not for the NAS-mounted disk- and filestructure. Is there another possibility?
  3. Trying to connect my virtual drives causes an error: : Mount Error. This message occurs wether Windows-Firewall is on or off. Exception for NetDrive is given in the Firewall configuration.
    Logfile says:
    [CRITICAL] [9240] [FILESYSTEM] Mount failed to initialize
    [ERROR] [9240] [FILESYSTEM] Mount failed : 2/Z:;;(Z, )
    [ERROR] [9240] [FILESYSTEM] CMounter::empty_mount Mount Failed 2008:Z:

I hope you can help me and give some solutions.



For problem 1, please attach debug log files to figure out what happened.

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no login related credential information in the log files.

For problem 2, I need more details for your environment. We recomment to use webdav if you are using QNAp

For problem 3, could you let me know what the drive item you tried to mount name is?
And I guess our filesystem drive was not loaded. It could be caused by some reasons like as a anti-virus program or a anti-malware program.

If you have further help, we can have a remote session via AnyDesk.



thanks for your response. I think a session via AnyDesk would be best.


Thank you for feedback.

Please let me know your AnyDesk Address and the time you are available with UTC>

You can download it from


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.