Nd3cmd.exe not working properly after last update

Hi, i used command (before update from 3.11.204 to 3.12.246):
“C:\Program Files (x86)\Bdrive\NetDrive3\nd3cmd.exe” connect -n “Drives.WebDAV”

And everything worked fine.
But, after update console began to ask:

account >>
pwd >>

but why ?
netdrive is already logged in!

Everything worked before updating

Dear artemsv-mail,

Thank you for using NetDrive.

When connecting, enter the user account and password together.


nd3cmd connect -n “drive name” [-u useraccount] [-p password]
nd3cmd connect -i id [-u useraccount] [-p password]

Connect a drive. “id” is a drive item’s id. The id can be got by a command “drivelist”.

-n : Connect a drive by drive name.
-i : Connect a drive by id


nd3cmd connect -n WebDAV -u email@host.com -p password
nd3cmd connect -i 1432

Please refer to the manual URL below.


nd3cmd.exe connect -n “Drives.WebDAV.X” (without useraccount and password) works successfully in NetDrive 3.11.204
it doesn’t work in NetDrive 3.12.246

I rolled back the update and everything works !
you have an error in 3.12.246

Why would I need to specify a username and password in the console? It’s not safe !!!
My NetDrive is already logged in and I just give the command to connect the drive by name “Drives.WebDAV.X”


I will check about this issue and feedback to you.


Thank you very much

Could you try with a following url version?



I tried to login to the console:

Ind3cmd.exe -u myUser -p pwd -k (keep me logged in)

And everything worked ! BUT

After that, 3.12.246 UI was automatically disconnected from the account


пн, 26 окт. 2020 г. в 07:40, jyyoon@bdrive.com via Bdrive Support Forum - NetDrive and CloudSync <no-reply@bdrive.com>:

Did you try with above 3.13.268?

Thank you, everything seems working with new version

The fixed version will be included in next release version.