Google Drive - User Rate Limit Exceeded

Good morning All,

I keep getting disconnected from my Google Drive account while using NetDrive3. The logs show the following error:

“domain”: “usageLimits”,
“reason”: “userRateLimitExceeded”,
“message”: “User Rate Limit Exceeded”
“code”: 403,
“message”: “User Rate Limit Exceeded”

I never had this issue with NetDrive2 so I am wondering if there is some setting that I need to set to prevent this. I did notice this was a problem with NetDrive2 in a forum post and it appears there was an update that fixed the problem. Any thoughts on how to prevent this in the future?

I checked my logs and also see this, explains the disconnects I been having.

It would be nice if the net drive team would at least acknowledge this issue and say they are working on it or at least looking into it.

This issue has been going for almost a month now.

NetDrive3 shares google API rate to all request to google among NetDrive3 users.

You should use your private google API key to prevent rate limit(same problem happens on NetDrive2).

In your account page, you can find this section.

Also please refer this article to get your private google API key.


Fantastic. Thank you, though the article referenced below I do not have access to. :slight_smile:

Was not aware that I had to use my private google API. I’ve added it and will see how it goes.

very funny… =P


That link has outdated directions and will give you an error.

Has anyone gotten there own API key to work correctly? I keep getting errors when trying. If so, please let me know what settings you chose to get it working.

Oops! Sorry it was my mistake! You should access article now.


Since @Alex corrected the link for the article, I can say that the information in that article is correct and should work. @Scottslegacy use the link that Alex provided and you should be all set for configuring the API. I wish the instructions I had back when I originally created mine were that good. :smiley:

1 Like

@praxia @Scottslegacy

There are lot of changes on google api page, so we have to update our instruction. Sorry about that.

We’ll update instruction as soon as possible.

Thanks Praxis, i did get it working eventually with some work. For some reason though the stage where you enter the localhost gave me errors when connecting.

Enter http://localhost on Authorized JavaScript origins. – changed to
Enter http://localhost on Authorized redirect URIs. – changed to

once i did the above, it finally worked for me.

EDIT: Soon after posting this, i got disconnected from the drive. Now connecting gives me Permission Denied. So looks like as Alex said there are some additional changes that are needed.

1 Like

[ERROR ] [ 10] [PROTOCOL ] Process >> Couldn’t resolve host name
[ERROR ] [ 10] [FILESYSTEM] [/Volumes/GoogleDrive] StatFs => ACCESS_VIOLATION : /
[ERROR ] [ 26] [PROTOCOL ] GetFileList >> ON HTTP 401 : FAILED(0x00000001)
[ERROR ] [ 1] [SERVICE ] [ nd3 sdk version - child nd3svc : 3.0.0 ] [Child.cpp:138]
[ERROR ] [ 1] [PROTOCOL ] Process >> ON HTTP 401 : FAILED(0x00000001)

were you able to solve this issue?

Nope, still waiting for Bdrive Staff to update the API page with current instructions. I sent a message asking for up an update but no reply yet.

It has gotten better by adding the API but I still get the occasional disconnect with the User Rate Limit Exceeded. Unless I am reading the API info wrong with Google, it is hard to fathom hitting 1,000,000,000 API hits per second.

We are sorry about late instruction has updated.

How to register your private google API key

Thanks for the updated documentation @Alex. I realize now what I had been doing wrong and just re-configured my API. I will see how it goes with the update. I will give it a day or 2 and then report back.

Thanks for the update Alex, will try it out and see how it does!

Update: after following the guide, everything went smooth, working great for about 90 min then stopped responding. Attempted to connect and now getting Access denied. When i go in the config a popup comes up saying Acess Denied. Please try again by pressing the CONNECT button.

If i hit the Connect button in config, i have to login again, once i do that it logs me in. This seems to work fine for a certain amount of time before it gives me an access denied error again.

Also note i have 3 separate accounts each with a different computer. With Netdrive 2 i was able to use the same API client Id and secret between the 3. I am also doing that here with Netdrive 3. Not for sure though if this could be causing a issue between the multiple accounts.

Same here. If I delete the drive and then add it again it works for about 90 minutes and just like you @Scottslegacy I get Access Denied when I try to re-connect the drive. Here are the last few lines of my LOG:

[2017/11/24 23:00:18.396] [ERROR ] [ 10332] [PROTOCOL ] GoogleDrive::GetFileList failed(HTTP 401) : {
“error”: {
“errors”: [
“domain”: “global”,
“reason”: “authError”,
“message”: “Invalid Credentials”,
“locationType”: “header”,
“location”: “Authorization”
“code”: 401,
“message”: “Invalid Credentials”
[2017/11/25 08:31:52.061] [ERROR ] [ 11516] [SERVICE ] [ nd3 sdk version - child nd3svc : 3.0.234 ] [Child.cpp:138]

Have not gotten the “User Rate Limit Exceeded” since yesterday morning though, but obviously now there is something else going on.

@Alex Thank you for all the assistance trying to get this worked out.

UPDATE Seems that the disconnects are getting more frequent now. @Alex Let me know if you want me to upload my log files to you privately. Maybe having the entire log file(s) will be more beneficial. Just let me know which one(s) you want.

UPDATE2 Disconnects were getting too much to handle so I have re-installed Netdrive2 though I am leaving Netdrive3 installed and running. Want to see if the disconnects occur as my ND3 install drive mapping has been changed to a different drive letter.

1 Like

UPDATE2 Disconnects were getting too much to handle so I have re-installed Netdrive2 though I am leaving Netdrive3 installed and running. Want to see if the disconnects occur as my ND3 install drive mapping has been changed to a different drive letter.

I have also switched back to Netdrive2 until this issue is fixed.

Nice to see the latest update doesn’t fix the issue.
Any chance of a working product one day?