Can't connect to Google Drive

NetDrive version: 3.4.393
Windows/Mac Version: 8.1


I managed to connect and attach a drive letter to my Google Drive once without a problem. I have now removed that Google Drive and am trying to setup a connection to a different Google Drive, which isn’t working.

When I try to connect, i log into the Google account without a problem and give NetDrive permission to control the drive and am told I can close the browser tab. Back in NetDrive, teh timer wheel is spinning next to the “Storage Type” drop down and nothing else happens.

Windows firewall is setup correctly, exactly as it was upon the first successful connection. I have un-installed and re-installed NetDrive, rebooted several times, all with no luck. I also tried the the first Google Drive that worked first time again, with no luck.

Any ideas?

Mr M

Downgraded to 3.3.349, which works.
Tried setting up a new google drive a few more times, each time worked fine with this older version.

I tried to reproduce your problem but failed.

Can you send us a log file please? It would be great help to us.

Sorry for the inconvenience it may caused.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.