You've reached maximum devices

I have been using CloudSync on a single machine since September. Yesterday it wouldn’t start up after crashing several times. Today I am getting the attached error about having reached the Maximum Devices allowed! I am only logged into a single device.

I need to get this back up and running ASAP



You can check your registered machines at

Please visit the page and deactivate one which you do not use.

While there are 2 machines listed, only one shows Active. The other was only used for testing when I first tried CloudSync out. I cannot delete it. It has been there since Sept 2019 so why would it all of a sudden be an issue?


Ok, so I reactivated the machine I haven’t used in months. I then deactivated it and deleted it. I tried opening CloudSync again and guess what? I am now getting the below error! lol

I guess I can’t use a computer to backup my data? lol

I think we need to check the issue with our license system.

I temporarily increased your number of license to 10. Please proceed with your backup.

Sorry for the inconvenience it caused and I will get back to you when we resolve the issue.

That worked! Thanks


I spoke too soon. While the app opened and logged me in, I am unable to click Sync Now and the auto-sync isn’t working either. Is that a licensing thing?

Sync Now and auto-sync isn’t related to the license limit.

I found that your device ID is recently changed. I’m not sure what caused the change but the device ID is read from Windows system and the ID can be changed by replacement of storage devices or network interface device.

If any of your sync item includes local disk as source or target and if the device ID is changed you cannot start the sync operation because local disk item only works from the machine where the sync jobs is first added.

I think you need to re-add your sync jobs from your current machine and it will fix the issue.

That makes no sense. I have this running on the same machine as I have always had it running on. The machine I deleted was just a test machine to see if I liked CloudSync, it was never used after my initial testing.

What device ID changed? So what is it that I need to do now?

Same machine but different device GUID which returned from Windows.

Previous Device ID - 6A4B776F6F47534362444A6446316972545A333054673D3D
Current Device ID - 6A4D31416D673836457A6C735133556A5043313455413D3D

Please logout and again to refresh local disk information.

Logging off/on did the trick! it is now syncing.



1 Like