WebDav - Seagate Personal Cloud

CloudSync (2.0.269 (build 269)) will not connect via webdav to my Seagate MyCloud local NAS after latest update. I can use the same configuration with the NetDrive 3 (3.1.286 (build 286)) and it works perfectly.

[2017/12/15 21:13:26.352] [MESSAGE ] [ 4860] [PROTOCOL ] Protocol::GetFileInfo >> HTTP PROPFIND >> 403 : - 3ms
[2017/12/15 21:13:26.352] [ERROR ] [ 4860] [PROTOCOL ] Protocol::GetFileInfo >> HTTP 403
[2017/12/15 21:13:27.509] [MESSAGE ] [ 7388] [PROTOCOL ] Protocol::GetFileInfo >> HTTP PROPFIND >> 403 : - 73ms
[2017/12/15 21:13:27.509] [ERROR ] [ 7388] [PROTOCOL ] Protocol::GetFileInfo >> HTTP 403

Please reproduce your problem after set to log level to DEBUG or VERBOSE in settings, and send us a log files please?

[DEBUG ] [ 1284] [PROTOCOL ] Protocol::GetFileInfo >> ON HTTP RANGE 200(207) : SUCCESS(0x00000000)
[2017/12/21 13:15:13.677] [ERROR ] [ 3304] [PROTOCOL ] Protocol::Connect >> URL using bad/illegal format or missing URL(3)
[2017/12/21 13:15:16.786] [ERROR ] [ 1284] [PROTOCOL ] Protocol::Connect >> URL using bad/illegal format or missing URL(3)

If you give me a place to upload the entire log file I will do that without issue. It works fine with NetDrive which is puzzling. I also verified the credentials by logging into my NAS and verifying the WebDav URL.

Thanks! It is known bug and will be fixed in next release.

WooHoo. I see the beta versions clicking along. Is it fixed in any of the beta releases? If so, even though I have that option checked the beta software is never installed or an option given to install it. Thank you for letting me know.

It’s not fixed in latest beta(3.1.310). It will be included next beta. Sorry about late.


NetDrive works OK, it is CloudSync that cannot connect to Seagate Personal Cloud via WebDav. It is still not working in the latest beta. I just tested it.

CloudSync will update within this week. And this will fixed.


Thanks. It is still not working in the beta released today.

CloudSync update will be released late today or tomorrow. Not released yet.

CloudSync beta has released today. Please try it.