Share Permissions on a folder drop (after reboot)

We’re using NetDrive3 to map in a folder from a vendor, we’ve manually added “Share” permissions on a folder within that mapped drive but when the server reboots it appears NetDrive3 re-mounts on every boot and the permissions aren’t stored by NetDrive3 it just drops it which results in the folder being invalid for users trying to navigate to it via it’s share path.
The only way to fix this is manually add the permissions back on, but this isn’t a solution to keep doing as we have regular reboot/patch schedules so that server has to be rebooted frequently.

Is there a way to fix this?


According to your message, when NetDrive re-mounts it’s drive it’s become a new drive and previous “Share” permissions are not applied to this new drive. What drive type did you use? Would you please try same configuration with other drive type?


Thanks for your suggestion. But it doesn’t work. When you change it to ‘network’ drive you can’t even setup ‘Share’ permissions.

We’ve got the screenshot attached of your NetDrive config, you can see where mapping it as a local ‘B’ drive from there we ‘Share’ the Bartender folder inside the NetDrive drive so you can access it at [\vgpafsql01\bartender$](file://vgpafsql01/bartender$)

When reboots happen on the bottom right hand corner of the screenshot the permissions ‘Epicor@PAF’ and ‘Bartender@PAF’ disappear, this is because NetDrive is disconnecting/reconnecting itself on server reboots and not keeping the permission.

Do you have other solutions?


With “server reboot” do you mean your FTPS server reboots?

The FTPS server itself isn’t rebooting, it’s the server on our end the client connecting to the FTPS server. We’ve got the setup type below for NetDrive’s info so there is a better picture of the setup

  1. ‘Epicor’ cloud application vendor on their end on their setup a folder on one of their servers.
  2. We setup an application on our end called ‘Bartender’, user’s at CleanSpace use ‘Virtual Desktop’ to access the application
  3. ‘Bartender’ users from step 2 need to see the folder from step 1, so on a client server we have on our end we use ‘NetDrive’ to map in as a local drive the FTPS server from step 1 using a link provided by Epicor
  4. Once the drive maps, users from CleanSpace need permission to access the drive that’s mapped in using NetDrive so we right-click and ‘Share’ a folder within the FTPS drive
  5. This works correctly and users from CleanSpace inside their Virtual Desktop via NetDrive can access the FTPS server

However when the client server in step 3 reboots, NetDrive seems to drop out and reconnect automatically but the permissions we setup in step 4 don’t exist anymore (only administrator’s can see the NetDrive FTPS folder now)

We can do a remote session on the server if needed, it would be the server that’s rebooting the one we use to connect to the FTPS

Please follow the steps below to retain share permissions after reboot.

These steps update dependency of LanManServer.

  1. Open command prompt with administrator permission

  2. List LanManServer dependency

    C:\> sc qc LanManServer

  3. Check current dependency

    Our test server’s LanManServer depends on Samss and Srv

  4. Add NetDrive system service to the dependency list

    You must include your current dependencies.

    C:\> sc config LanManServer depend= Samss/Srv/NetDrive3_Service_x64_NetDrive3

    Blank after depend=.

    Samss/Srv/NetDrive3_Service_x64_NetDrive3 on the same line without spaces.

  5. Check updated dependency

    C:\> sc qc LanManServer

After this change file sharing service will start after NetDrive system service.

You can also check current dependencies with Services.


Hope this helps.

We tried your steps and it didn’t work after a reboot, we can still see ‘NetDrive3_Service_x64_NetDrive3’ in the services but the ‘Share’ permissions on that folder have dropped out
As you can see in the screenshot we attached, we re-setup the share ‘Bartender$’ and added 3 security groups as permissions again

Once the server reboots that share gets removed and the users are unable to access the folder until we re-setup the share + add the permissions in

We are working on some changes which will ensure remote storage mounting before setting windows service status as running.

Thank you, do you have an estimate time for this?

I can’t confirm on the schedule because the engineer in charge is on vacation until the weekend.

No worries we’ll follow up next week for a resolution

Thanks for your patience.


Just chasing this up to see if the engineer has a timeframe on this?

Yes, we are working on it now.

No worries do you have a timeframe so we can let the business on our end know?
Will it be today, couple days, this week?

If the change works as expected it would be couple days.

Thanks we’ll follow up in a few days

Following version is changed to set Windows service, nd3svc’s state as running after mounting mount-on-boot drives.

You need to set LanManServer dependency as described before.

When you install this version you need to set sharing settings again because during the installation process your remote storage will be unmounted.

Thank you we installed that exe you provided for the new version and that looks to have solved the problem, we’re just getting our users to test tomorrow to see if there’s any further issues

1 Like