NetDrive Mobile cannot connect to BDrive server

iOS Netdrive Mobile app, at login to the app, receive error message “Failed to connect to Bdrive server.”

Background info:

  • App version “1.0.0”
  • iPad mini 6th gen, iOS 15.4.1
  • Issue does not occur on wifi, only on cellular data … previous has worked on cellular data (according to user)

Troubleshooting steps taken:

  • Confirmed cellular is available (can stream un-cached videos on the internet)
  • Confirmed NetDrive app has permission to use cellular
  • Confirmed login credentials are correct
  • Issue persists even when trying to log in with different accounts
  • Assigned an additional license to the account, still won’t connect

Any suggestions? User claims that is worked on data previously.

Could you try that after killing the NetDrive mobile app?


By “killing” you mean close the app and restart? Yes, I did not mention it, but that is one of the steps I tried. Also tried “restarting” the device (iPad). Just tried it again and the issues persists.

Any other suggestions or possible causes?

We tried to check server log but cannot find any connection attempts.

What email address did you use to connect using iPad?

Apologies for delay in response, I was out for a short vacation.

May I send you a direct message with the user’s login email? It is a publicly-facing email account, so I don’t want to post it on the forums.

The user is now in a different location (geographically) and is no longer experiencing the same issue. They are now able to connect when using cellular data. I cannot reproduce the issue at the moment.

What information can I gather or troubleshoot the next time this issue occurs?

Sure, you can send me private messages any time.

It’s good to hear that it works on celluar now.

We did some tests but we can’t find any clue to the problem yet. I think it’s related to Qt network stacks and try to find any relevant infos on the problem. (Qt is a framework we use to build apps).

Thanks for your feedback.