Netdrive 3 Stuck on connecting to netdrive Agent

NetDrive version: 3.7.687
Windows/Mac Version: Windows 10 Professional


I’ve been using NetDrive 3 for a bit on another computer where it works fine, but when installing it on a new computer it doesn’t seem to work.

It Always gets stuck on Connecting to bdrive agent…
Both the NetDrive 3 agent/service services are running.

I’ve tried installing older versions of NetDrive 3, but those either have the same error or don’t get past initalizing at all. NetDrive 2 works fine though.

1 Like


Could you attach debug log files to figure out what happened?

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no credential information in the log files.

Or we can have a remote session to figure out via TeamViewer.

If you want to, let me know your TeamViewer ID, passsword and the time you are comfortable( including your timezone).


Hello, thanks you for the response.

I would add a debug log, but the problem is I can’t change the log level since it won’t even let me log in while its trying to connect to the netdrive agent.

TeamViewer is fine. I’ve send you the details in a private message.

Did you manage to fix this? (I am having the same problem.)

1 Like

Hello Andrew

The problem with webmaster-f7db was caused by a virus.

You can refer to below.

Hi – thanks. Yes – both
NetDrive3 Agent (Product NetDrive3) and NetDrive3 Service (Product NetDrive3) were not running.

Once I start them again, it works fine. However, every time I reboot I now have to start these services (despite them being set to automatic). Do you know how to fix this?

Many thanks

What is the “Startup type” of the both services?

The status must be “Automatic”.

Some anti-virus program or anti-malware problem could change it.


Hi – it’s set to automatic. It’s very strange – I’ve noticed that some of my other programs are not starting up automatically too.

I have no idea how can help you.

Same issue, it takes a long time to login it seems stuck on it… and I have 6 accounts…

It login but it takes a long timeee :slight_smile:


Could you refer to the following topic?

It will be helpful for you.