Mount Error on Windows 10 insider preview version


Mount error occurs when I try connect my storage (all kinds of types).
I’ve updated windows 10 insider preview version over 17063.

I hope netdrive(or windows?) to be fixed quickly.


Thanks for let us know.

Did you update to Windows 7 or Windows 8 to 10 with NetDrive installed?
If you so, please reinstall NetDrive.

No. I have used Windows 10 from the beginning.
This problem occurs from version 17063 (insider preview) even if reinstalled NetDrive.

Dear xero.

Are you using anti-virus program or anti-malware program to protect pc?
If so, let me know which program you are using.

I think the device driver NetDrive using is blocked by something like above programs

I just upgraded to Windows 10 Education Insider Preview Version 1709 Build 17074.rs_prerelease_flt.180166-1539 and now I have a mount error with all storage–Dropbox, Google Drive, One Drive, and multiple SFTP sites. I have a Surface Pro 4 and have run Windows 10 Education Insider Preview since the beginning. I use Windows Defender Security Center–I already was using Windows Defender, but apparently the Security Center is new with this update–and have turned both off the Windows Firewall and Anti-Virus protection and still have the mount errors. WinSCP still connects to SFTP drives with no issues.

You can experience ‘Mount Error’ right away, If you installed Windows 10 insider preview latest version.
(I use the windows defender only.)

I’m also suffering from this - I have tried both netdrive 3 & 2 (via installing and uninstalling) and get the same issue with both on Build 17074.rs_prerelease_flt.180166-1539 (same as trygstad above).

Netdrive connects to the remote server ok (sftp in my case but fails to mount it)

verbose log returns

[2018/01/23 10:06:01.435] [DEBUG ] [ 5740] [SERVICE ] pipe id _7, [MsgProcessor.cpp:188]
[2018/01/23 10:06:01.441] [DEBUG ] [ 5740] [SERVICE ] execute_child is succeed : “C:\Program Files (x86)\Bdrive\NetDrive3\x64\nd3svc.exe” -c _7 “” [ParentPipe.cpp:67]
[2018/01/23 10:06:01.484] [DEBUG ] [ 5740] [SERVICE ] MsgProcessor::Mount:: pipe \.\pipe\nd_mount_7 is created [MsgProcessor.cpp:250]
[2018/01/23 10:06:01.484] [DEBUG ] [ 5740] [SERVICE ] MsgProcessor::Mount:: pipe \.\pipe\nd_mount_7 is connected [MsgProcessor.cpp:258]
[2018/01/23 10:06:01.746] [ERROR ] [ 5740] [SERVICE ] MsgProcessor::Mount:: failed to mount. label:, pipe: \.\pipe\nd_mount_7 [MsgProcessor.cpp:273]

@robin-fairless @xero @trygstad
Dear Customers.

We found the solution of this issue.

Refer to this url of Microsoft to add value “IoBlockLegacyFsFilters”

The default value of “IoBlockLegacyFsFilters” is 0 according to above url. But In insider preview, the defaule value of “IoBlockLegacyFsFilters” is changed from 0 to 1.

So If you add “IoBlockLegacyFsFilters” value and set 0, NetDrive will work well.

  1. Uninstall NetDrive and reboot.
  2. add “IoBlockLegacyFsFilters” value and set 0 to registry.
  3. install NetDrive again.



Hi Jyyoon,

Thanks for this, it is a massive lifesaver.

I have tested and can confirm it is working (I just shut NetDrive 3, did the registry edit and rebooted, no need to uninstall/reinstall) and it is great to be able to use NetDrive again.

Will this registry modification be added to the installer for future versions?

Thanks for the investigation and response & fix.

Thank you for your feedback.

We will consider about that.