Issues trying to run NetDrive3 for the first time

NetDrive version: 3.4.393 (Build 393) - 03/15/2018
Windows/Mac Version: Windows Server 2012 R2

I’m trying out the NetDrive product line in hopes of being able to run batch files as scheduled tasks and preform tasks such as database backup copy commands to the Google Drive cloud that my company has.

I have previously tried ExpanDrive and was able get to about 98% of the way finished with my goals. In their case everything worked perfectly when running the batch file in a CLI window while logged in as the user AS WELL AS running a CLI window as the user preforming the task. The reason I’m trying NetDrive is because I could not get ExpanDrive to work successfully when running the batch file as a scheduled task.

In my initial installation of NetDrive on my server it installed fine. After logging into my trial account for my team drive (bdrive account) I was trying to add my Google Drive account (team drive). It seems to just have a spinning circle after I press the connect button. At this point it’s just stuck at that screen and nothing is happening.

A browser window is invoked to complete the login process for the targeted provider and to grant permission to NetDrive to access your cloud service account API. On Server 2012 R2 & Server 2016 you need to have an alternate browser installed and the installation needs to be done from an administrative account. This is due to the limitations that M$ places on the use of IE with administrators accounts in all versions of Windows Server 2012 R2 & above.

Add it as a trusted site or disable enhanced security.

If your server OS uses internet explorer, you have to use another browser. OAuth login with google will not work perfectly with internet explorer.

First thing, the second thing I always do on a Windows Server install is installing Chrome. I hate IE. I ended up trying to roll back NetDrive to an older version. I was reading some posts online and they ended up rolling back too.

I ended up uninstalling NetDrive 3.4.393 and installed version 3.1.196 afterwards. I currently have it working as I expected but now it’s giving me another issue now…

I have set up a scheduled task that runs a batch file which runs NetDrive (when my virtual drive created by NetDrive does not exist). This runs just fine when I run the batch file manually. It does not work when I run the batch file as a scheduled task. Any ideas why?

Scheduled task will runs under system service. That’s why NetDrive will not run. Scheduled task has feature that run as user but this is not same as run NetDrive after user login.

NetDrive have to run on user interface not impersonate.

So Alex, using NetDrive for scheduled tasks is just simply impossible?

For now, yes. Can I ask why are you want to use scheduled task?

Alex, like I was saying in my original post, I need to run a scheduled task for the same reason everyone else would ever run a scheduled task. For my server to do a job over and over again without me having to monitor or run said job.

This has to be a scheduled job that’s being ran by my batch file as well as running as a specific user I have set up with the appropriate access. My server does not have users logged on to it often. My scheduled task needs to be able to be ran without any help. Are you suggesting I should not be using a scheduled task?

NetDrive can mount drive on boot(don’t need to log in), I think you should try this.

Drive will always mounted even reboot then you can run your job on scheduled task.

Thanks awesome Alex! I never knew that. What user’s access would it use? For example, say I was logged in to Windows on my server as USER1 (my admin account) then used the Gui to set this up (not sure what that looks like yet as I have only created a drive when the user is logged on). When I restart the server and then ONLY logon to Windows with account USER2 (my sql backup user account with standard rights) would the virtual drive still be available? Also, is that user able to control the drive being mounted/unmounted as well or does it just show up as a system drive?

Now that I’m typing all this, maybe I have used it before… Are you talking about the difference between a NETWORK drive vs a LOCAL drive?

Sorry for the quick response but I just found it under the Auto Connect Options.

Let me give it a try, THANKS!!


All users on server can access to drive when mounted on boot.

OK Alex, It looks like NetDrive is going to work for me. I even have the latest version installed and working (it would not work for me before when I was using it for the first time). Thanks for the help.

Btw, before this thread gets closed… Who can I contact about licensing issues? I had someone from purchasing in our company by a license but it’s attached to their email address and I need to change all that info.

Please leave message here about licensing issue.

Our staff will contact you as soon as possible.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.