Install mistake / can't update

I have download Version 3.14.309 from


The *.exe file was shown in my Download Folder


After installing the software i look into the ABOUT screen, i see that i have install Version 3.7.687.


After a few seconds the program shows me a hint for updating to ver 3.14.309

Clicking the link downloads something. After installing this “Something” theres ver 3.7.687 again.
…and so on and so on …

What the hell happens here ?

Dear andreas-konietz,

Thank you for using NetDrive.

Please completely uninstall NetDrive 3.7.687 first and then reinstall NetDrive 3.14.309.

If you issue persists, please let me know.


Thank you for your message.
After uninstalling the software and then restarting the computer, the Netdrive symbol still appears in the task bar next to the clock.
The uninstallation routine is obviously not working correctly.

I’m having the same issue trying to update the software, which looks like it’s pretty common on this forum. I have tried updating the software when prompting that an update is available (about 5 times this morning) and I don’t get any warnings or errors. When I launch the software it still launched the old version, even though the new version is listed in Programs & Features. I also downloaded the latest version (Quit NetDrive in the taskbar) and tried installing this. No warnings or errors but the old version is still there.

Is there a working solution to update the software? Don’t want to uninstall & restart a production server for a proposed solution that doesn’t work.

Dear itmgr,

If you are updating from a version earlier than NetDrive 3.7, you will encounter problems when restarting the service. In this case, you need to install the new version after uninstalling NetDrive.

From later versions, you can update immediately without restarting.


Dear andreas-konietz,

Would you like to install a new version to see if the old Tray icon remains?


I noticed that when I hover the mouse over the tray symbol, the following message appears:
“Connecting to NetDrive Agent”.
When I double-click the tray symbol, the login screen appears, but I cannot enter my password.
Right-click on the tray symbol is not possible.

I guess an messy deinstallation

meanwhile i have managed to install the current version

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.


Thank you for using NetDrive.

I can help you having a remote session.

If you want to have, please let me know you your AnyDesk address and the time you are available with UTC.

You can download it from