Files STUCK in waiting

It appears that some files are stuck in “WAITING” to be transferred to my FTP cloud drive. Is there a way to make sure that this does not happen and to extend the # of files that can be I assume BUFFERED while they are waiting to be uploaded?? I am archiving data from 6 DVD drives at the same time and need to have them transfer the data using this FTP connection. Thanks in advance for the assistance.


Thank you for using NetDrive.

When the background upload option is set, only 4 files are transferred at the same time.

If you uncheck the “background uploading” and check “on-the-fly” option, the uploading is synchronous with explorer, but it’s slower than before.


So this will fix the STUCK issue with the files?

Also is tehre a way to set the BACKGROUND upload to more than 4 say 10?


Unfortunately it’s impossible to change background uploading count from 4 to 10 at now.

I will consider it to optional value later.

I have changed the setting to UPLOAD using ON THE FLY. Now I am getting an error that says FTP CACHE ERROR, How do i fix that and it wont let me switch back to the other setting it also gives me the error there too now…

Never mind I just deleted the drive and re-created it and it worked.
but ON-THE-FLY is very very slow 1 at a time file uploads any way to speed that up?


Yes, on-the fly option makes uploading slow.

I will research this issue to resolve your problem.

Then feedback to you.



I found the way how to change numbers of the background uploading.

Pleaes open a file (C:\Program Files (x86)\Bdrive\NetDrive3\x64\ndfs.ini) by administrator’s right with text editor like as notepad.

Then add two lines below.


The file edited is attached.
ndfs.txt (84 Bytes)

You must change the file extension from .txt to .ini after downloaing above.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.