Error after upgrading to macOS Big Sur

same here:-(

same here :frowning:

Same issues faced after the update to OSX Big Sur

Та же проблема. После обновления на Big Sur теперь не подключается ни к каким удаленным дискам по WebDAV

Same problem! Hope this is sorted out asap…

Please try re-install NetDrive 3.13.300. It seems that system extensions installed before installing Big Sur have security permission issue.

For other users with NetDrive 3.12, please update to NetDrive 3.13 and you need to follow the steps in following article.

Hello, i have installed the 3.13.300 but still have the issue with the extension. I have restarted to load the extension but each time, the extension is not unlocked.

1 Like
  1. on OS X Big Sur
  2. also updated to NetDrive 3.13.300
  3. also followed YSH tips - looks a bit different with OS X Big Sur
  4. But now I got stuck and NetDrive no longer responses to anything

So what is the next TIP on how to solve this?

I also continue to have the same issue. The window in point 3 of the FAQ “How to use Netdrive on macOS Big Sur” does not open. I get option to restart after clicking “Allow” in the “security and privacy” section. After restart, the problem persists. The solution in FAQ “How to use Netdrive on macOS Big Sur” simply does not work.

1 Like

Totally agree - same issues

I am having same issues…


I captured the images from Big sur beta.

I will revise the topic as soon as possible.

Please Could you follow the below steps?

  1. Uninstall NetDrive using uninstall.tool in NetDriveInstaller.dmg

  1. Then Reboot.

  2. Reinstall NetDrive 3.13


Thank you and I tried the suggestion of using the uninstall tool and then reinstalling NetDrive V3.13.300. It loads the app (after a restart) but hangs when connecting to a server that I know is working because I’ve accessed via another route. Please fix this as NetDrive is not working at all for many who have ‘upgraded’ to Big Sur - or at least say what is the problem and the plan to fix it. Thanks.


It’s very wierd thing because I have no problem on Big Sur.

If you are available, let’s have a remote session to figure out what problem is.

If you want, please send me a Private Message.


Please check if NetDrive Kernel extension is allowed.

In terminal:

$ sudo sqlite3 /var/db/SystemPolicyConfiguration/KextPolicy

SQLite version 3.32.3 2020-06-18 14:16:19
Enter ".help" for usage hints.
sqlite> select * from kext_policy; 
4M7G2HXTMV|com.bdrive.ndfuse.filesystems.ndfuse|1|Bdrive Inc.|1

You can see com.bdrive.ndfuse.filesystems.ndfuse and number 1 in next column. ‘1’ means allowed.

Yes, the kernel extension is allowed, but Netdrive does not work. I got the same result in terminal following your instructions - 1 meaning the extension is allowed.

Okay - I did this now 3 times and still no connection can be established.
What I found strange is that it seams to remember the connection details - should that not be also deinstalled and I need to set it up again?
Whats next?

@tucnyj If kernel extension is allowed please send us debug log.

After setting the log level to VERBOSE, please reproduce the problem and send us the debug log file :

There is no login related credential information in the log files.

Thanks. Please attached the log files. (23.1 KB)

Hi, netdrive looping.
No kernel extension allowed