Connection to SFTP with username no password and private key doesn't work

I need to connect a drive to a SSH server, in CLI I use ssh user@host and the private/public keys stored under mi profile, via this way a can connect with no problems, but I need NETDRIVE to work the same way, but keeps asking for a password … that’s wrong!!


Sorry for late. I missed this one.

Are you using open-ssh private key format or putty format?

Unfortunately, NetDrive supports only openssh format.

Could you check the url of your sftp drive item?

NetDrive doesn’t support user@host format url. User account must be set in “User” edit box.



In Windows 10, MacOS and Linux I use Open-ssh for all related ssh tasks.

Jorge C. Henriquez Tolhuysen

I tried to reproduce your issue but I failed to reproduce it.

If you can give me a test account and private key file for the account, It will be very helpful to solve it.


Server Address:
UserName: jyyoon
Password: $%jyy00N
Identity Files: (759 Bytes) jyyoon.txt (3.3 KB)

Had to add .txt extension to filenames to upload them.

I’ve tested the following:

sftp -i .ssh/jyyoon
sftp -i .ssh/jyyoon -o User=jyyoon

both works as expected, no password required.


Thank you for your help.

I tested with the files you attached and I can confirm that the issue happens.

I will try to fix the problem asap and post a beta version here.

Due to my vacation from tomorrow I think I can post a beta version in next week.


It seems that the key file format is the origin of the problem.

Would you try creating the key files using -m PEM option to create in RSA format?

Please refer to the following page:

If this solves the issue we need to update our underlying libraries to support new key format.

Thanks for your feedback.


I’m glad to inform that generating the key with the suggested option solved my problem.


I appreciate you letting me know the result. We will update our underlying libraries.

Thanks for using NetDrive!