Cloud sync issue syncing onedrive files to DropBox

Dear community members,

As a newbee yesterday set up Cloudsync jobs for:

  • Syncing foto back-up from Onedrive to DropBox
  • Syncing data backup from DropBox to Onedrive.

For both jobs folders and files in the ‘root’ folder are synced
For Dropbox -> OneDrive subfolders AND files are synced to DropBox
For OneDrive-> Onedrive subfolders are synced to DropBox, but files are not synced, BUT the job shows 4500+ files synced though

What am I missing?

Thanks

Dear t-koopman,

Thank you for using CloudSync.

CloudSync supports only sync between subfolders.
You need to put those folders under one parent folder to sync.

Regards.

Thank you for reaching out and responding this quick. Much appreciated. Maybe I need to clarify the issue a bit better What I set up is:

JOB ONE:
Sync one folder + subfolders from DropBox to OneDrive

Root/parent
Root files
Sub folder 1
Files subfolder 1

Sub folder 2
Files subfolder 2

Works as expected and transfers all files and folders

JOB TWO
Sync one folder + subfolders from Onedrive to DropBox

Root/parent
Files Root
Sub folder 1
Files subfolder 1
Sub folder 2
Files subfolder 2
Works partially

All folders and subfolders are copied

All files in the root folder are copied

None of the files in each of the subfolders is copied

The job finishes without errors and states that all files are copied (+ 4500 files)

It therefore seems to has to do with copying large numbers of files (approx. 65Mb) from OneDrive to DropBox

Dear t-koopman,

Would you like to set the log level as below and try again for the operation that does not copy files?

If you send us the following debug log file, it will help us to check your issue :

  1. Open your CloudSync UI
  2. Stop current sync jobs
  3. Click “Settings” button
  4. Select “VERBOSE” from Log Level field
  5. Repeat steps to reproduce your issue
  6. Click “Open log folder” to find “cloudsync.log” file

Sorry for causing any inconvenience.

Regards.

Hi there,

Looks like there are some inconsistencies. Cannot really get clear insights but looks like bugs.

Following your guidance, noticed a couple of unexpected things all related to synching Onedrive to Dropbox.

General info: Running Mac OS High Sierra 10.13.6

Cloudsync version 2.3.9

Running on MacBook air

What I did;

First of all secured the old log files (also attached as .old .old2 and .old3)

Two tested what happens if I sync only one under the subfolders beneath the OneDrive root folder based on a new created job

Outcome  Works as expected

Changed the subfolders from the new created job to other subfolders under the root

Outcome  In the UI while selecting the new foldername sometimes the app crashes selecting the to folder

Outcome  In the UI after saving the new foldername sometimes the changes do not seem to get saved (tested this reopening the job again

Outcome  Stopping the app and reopening again the changes are visible trough the UI (!) and seemed to be changed in the background

Three removed the initially created job for the root folder and recreated the job for the root with the same specs

Outcome  Still not all folders are synced and the job finishes in just a couple of seconds (See error.log)

For now the only resolution seems to be a manual sync for all the subfolders to overcome this issue

Hope this helps find the cause and help me to resolve the issue

Thanks

cloudsync.log (169 KB)

cloudsync.old.log (6.54 MB)

cloudsync.old2.log (606 KB)

cloudsync.old3.log (1.17 MB)

Dear t-koopman,

There seems to be a failure to create a privé diversen folder. Would you like to change it to a different name and try again?

2021/01/12 19:42:31.350] [ERROR ] [ 2] [PROTOCOL ] CreateDirectory >> ON HTTP RANGE 400(409) : AERROR::CAN_NOT_MAKE(0x00000015)
[2021/01/12 19:42:31.350] [ERROR ] [ 2] [CLOUDSYNC ] Folder /privé diversen create failed : (null)(retry left : 3)
[2021/01/12 19:42:31.507] [MESSAGE ] [ 4] [PROTOCOL ] Upload >> HTTPS POST >> 200 : https://api.dropboxapi.com/2/files/get_metadata(429) - 427ms

And can you send me a screenshot of the Sync Item settings?

Regards.

Changed the folder to another name. Would also love to share the settings, but…

Was asked to install the latest package and now not able to start cloudsync at all… See below… :frowning:

Process: cloudsync [568]

Path: /Applications/cloudsync.app/Contents/MacOS/cloudsync

Identifier: com.bdrive.cloudsync

Version: 1.0.0 (0)

Code Type: X86-64 (Native)

Parent Process: ??? [1]

Responsible: cloudsync [568]

User ID: 502

Date/Time: 2021-01-15 18:14:03.032 +0100

OS Version: Mac OS X 10.13.6 (17G14033)

Report Version: 12

Anonymous UUID: 0C2A1B63-452D-BB3E-15C0-E97EE66B3508

Time Awake Since Boot: 100 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)

Exception Codes: 0x0000000000000000, 0x0000000000000000

Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x4] Symbol missing

Application Specific Information:

dyld: launch, loading dependent libraries

Dyld Error Message:

Model: MacBookAir6,2, BootROM 122.0.0.0.0, 2 processors, Intel Core i5, 1,4 GHz, 4 GB, SMC 2.13f15

Just installed a previous version of the package. Cloudsync now works again, the issue is still not resoved though. Will send a new logfile. Also two crashes of the app that require a restart of the app

And the promised logfile

cloudsync.log (2.9 MB)