Can not add/authenticate any drives

NetDrive version: 3.5.434
Windows/Mac Version: Windows 10 x64 insider Preview 17735

I have tried this version and the version. I have not successfully added a single drive. I have tried Box, DropBox, …all of them. In each case I get the spinning wait cursor, “<-- Wait For Authentication” message which never goes away. When I click the arrow to go back, I get an error dialog titled, “Authentication failed”, with a message that reads “Authentication with Box has failed.” Or any other storage provider. NetDrive 2 worked fine. What do I do? Thank you.

What browser do you use?

Can you see any browser running when you try to login your cloud storage?

Thank you for responding. I primarily use Firefox, although IE and Edge are installed. I have no browser up.

I was able to create an SFTP mount as a network drive for my QNAP NAS. The issues I describe are limited to Box, DropBox, hubiC, Google, OneDrive, Amazon. These are clouds that I can not create a mount for.
I tried from the network at school, and I tried from my network at home. On both networks I can log into the various cloud providers using their web sites and their Windows applications.

I just installed NetDrive 3 on another Windows 10 x64 machine with the same Windows Insider Preview build. In this case, when I went to add Box, the Chrome browser launched and asked for login credentials. On the machine I’m having problems with NetDrive, Chrome is not installed, not does any of the three browsers that are installed launch. I tried opening each browser manually and leaving it up, but NetDrive does not appear to attempt to create a new login page in any of them.
Does NetDrive 3 only work in Chrome?

I resolved the issue. The default browser setting was corrupt in. I went into settings in Windows 10 and reset the default app defaults, and now Edge comes up when I try to add a drive in NetDrive 3 and I am correctly asked for login credentials. It’s all good now.

1 Like