Backblaze doesn't work with application key

I just tried mapping a bucket from Backblaze B2, but it appears it only works when using the master key. If I create an application key, NetDrive can’t access the file list. The error log is showing error 400.

[2023/05/22 10:31:13.377] [UNKNOWN ] [   28664] [FILESYSTEM] File::FetchList : forced [NO]
[2023/05/22 10:31:13.377] [UNKNOWN ] [   28664] [FILESYSTEM] Fetch file list SYNC
[2023/05/22 10:31:13.431] [ERROR   ] [   28664] [PROTOCOL  ] BackBlazeB2::GetFileList_BucketList >> HTTP 400

I’ve tried various settings in the new application key dialog on Backblaze (read only, read&write, all buckets, just one bucket, etc), but to no avail.

Alternatively, Backblaze allows a connection through the S3 protocol. Unfortunately NetDrive only supports the Amazon servers. There are more 3rd parties that support S3, it would be nice if NetDrive allows you to specify an S3 server address. Excuse me, I just found the generic S3 connection type :). This actually works with an application key for Backblaze!

Thanks for your feedback. I will add your request to our list.

You can specify S3 server address when adding S3 drive item. Click ‘CONNECT’ button shows a window where you can change server address.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.