Authentication with Webdav Failed

Hi All!,

So, I’ve run into an issue getting netdrive to work properly on a new machine. The user is completely setup with bdrive and synology accounts, however, were are unable to get it to actually connect to the drive. I’ve tried this with the same user credentials on different machines, and everything works fine.

I’ve attached the log files. I’ve uninstalled and reinstalled multiple times, and rolled back to a previous version as well all with no success.

We’ve done this for dozens of users, and haven’t run into this issue, and this is a brand new machine.


NetDrive3_kbola.log (45.0 KB)

Dear kmendoza,

Thank you for interesting in NetDrive.

Would you like to check if the port is set correctly?
The log file you attached has the following log.

[2020/10/06 17:15:29.048] [ERROR] [2472] [PROTOCOL] Protocol::Connect::<lambda_53c7a738315fbff2ed33838733f9ecad>::operator () >> Got auth type but not support

This is mainly caused by port configuration issues.
See other topics.

Check Port Number of Synology NAS WebDAV

Check whether the port number of Synology NAS WebDAV is correctly set in NetDrive Drive Item WebDAV.

If you issue persists, please let me know.


Thanks for the quick reply.

I have set it up exactly as shown above, and as stated this is the ONLY user giving us this issue. If I enter the incorrect credentials, it throws login error.

Previously, when attempting to build a webdav connection, on this same machine, it would lock up trying to validate the connection, and would never time out.

I’ve uninstalled and reinstalled probably 8 times, over different builds, with and without updating in place. The same configuration works on all my other users, as well as this user when I tested the credentials from a different machine/location.

Dear kmendoza,

Would you like to check some checklists for Synology NAS WebDAV connection problems?

Check Access Permission of WebDAV Server

“WebDAV server” permission can be set in “User” menu in Control Panel of Synology NAS DSM.

Go to “User” menu in Control Panel and select the user to connect to WebDAV, and then click “Edit”.

Go to “Applications” tab and select “Allow” in WebDAV Server field.

Check IP Block List in Synology NAS DSM

Check whether user ID is registered in auto block list in Synology NAS DSM. If user IP is included in the block list, remove the IP from the list.

Check Router Setup

Router setup information seldomly changes after software update of the router. If port forwarding option is used, it is necessary to check the port number.

Restart Synology NAS

Occasionally Synology NAS WebDAV application does not operate normally. In this case, connection failure occurs when trying to access to WebDAV from the internet. It is recommended to restart Synology NAS and then retry the connection.

If you issue persists, please let me know.
And a screenshot will be helpful.


So, we’ve done all of the above, except restarting the Syno. I’ll try that this eve, and see if it changes anything, but currently as the login credentials work from another computer/location, I don’t think it will fix the issue.

Anything else you can think?

Did you check “block list” in DSM of the Synology?

yup! nothing in the block lists on the synology, or the user’s modem. it’s wide open. Even tried turning off windows firewall with no results. Again, if I enter incorrect credentials, it throws a credential error, so it’s able to at least communicate with the synology for account authentication…

I’m going to try a different internet connection, and if that still doesn’t work, I’m going to restore windows to factory and try a clean install… but that’s really the last thing I want to do remotely =\

updated SSL cert on Synology, and ran some windows updates… That seemed to fix it… Not sure if it was one or the other, or both, but yeah… it works now. thanks!

Oh, it’s a good news.

Don’t hesitate to contact us.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.