3.4.398 version - SFTP Can't connect

NetDrive version: 3.4.398
Windows/Mac Version: Windows 10

Just upgraded to NetDrive 3.4.398 and my SFTP drive will no longer connect. Debug logs are useless, but shown below. I tested using FileZilla and it connects fine. This worked up until I updated NetDrive. I have rebooted twice, deleted the drive and tried to recreate it. Now I can not “save” it since it will not connect.

Will reboot one more time after deleting the drive to see if that clears something.

Log:
[2018/03/25 11:52:48.341] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Rebuilt URL to: sftp://[TRIMMED]:22/
[2018/03/25 11:52:49.936] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Trying 192.168.1.231…
[2018/03/25 11:52:49.936] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] TCP_NODELAY set
[2018/03/25 11:52:49.936] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Connected to [TRIMMED] (192.168.1.231) port 22 (#0)
[2018/03/25 11:52:49.967] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Failure establishing ssh session
[2018/03/25 11:52:49.967] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Closing connection 0
[2018/03/25 11:52:49.998] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Rebuilt URL to: sftp://[TRIMMED]:22/
[2018/03/25 11:52:49.998] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Hostname [TRIMMED] was found in DNS cache
[2018/03/25 11:52:49.998] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Trying 192.168.1.231…
[2018/03/25 11:52:49.998] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] TCP_NODELAY set
[2018/03/25 11:52:50.014] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Connected to [TRIMMED] (192.168.1.231) port 22 (#1)
[2018/03/25 11:52:50.030] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Failure establishing ssh session
[2018/03/25 11:52:50.030] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Closing connection 1
[2018/03/25 11:52:50.061] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Rebuilt URL to: sftp://[TRIMMED]:22/
[2018/03/25 11:52:50.061] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Hostname [TRIMMED] was found in DNS cache
[2018/03/25 11:52:50.061] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Trying 192.168.1.231…
[2018/03/25 11:52:50.061] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] TCP_NODELAY set
[2018/03/25 11:52:50.077] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Connected to [TRIMMED] (192.168.1.231) port 22 (#2)
[2018/03/25 11:52:50.092] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Failure establishing ssh session
[2018/03/25 11:52:50.092] [MESSAGE ] [ 9496] [NETWORK ] [INFORMATION] Closing connection 2
[2018/03/25 11:52:50.123] [DEBUG ] [ 9496] [PROTOCOL ] Protocol::Connect with explicit FTPS url:sftp://[TRIMMED]:22, return 1
[2018/03/25 11:52:50.123] [MESSAGE ] [ 9496] [CACHE ] Uninitialize cache…

1 Like

Yuck, have to update the SFTP server to support some different cyphers…

Working now, but not the best solution to downgrade my security cyphers. At least this is behind my firewalls.

Well at least you are in a position to adjust your config. I don’t have root on all the systems I connect to.

I really hope @ysh figures out some method to switch back to using OpenSSL, instead of the crappy WinSSL library, with its limited ciphers.

Not sure if this works, but there is a way to add ciphers to WinSSL on your NetDrive3 computer… Perhaps that will help you… Since my SFTP is working now, I am not going to alter anything…

To configure the SSL Cipher Suite Order Group Policy setting, follow these steps:

  1. At a command prompt, enter gpedit.msc, and then press Enter. The Local Group Policy Editor is displayed.
  2. Go to Computer Configuration > Administrative Templates > Network > SSL Configuration Settings.
  3. Under SSL Configuration Settings, select SSL Cipher Suite Order.
  4. In the SSL Cipher Suite Order pane, scroll to the bottom.
  5. Follow the instructions that are labeled How to modify this setting.
    You have to reboot

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.