OneDrive for Business connection issues in NetDrive3


I’m testing NetDrive to see if it is a good option for our company and I’m facing some issues related to the OneDrive for Business network mounting.
What we want to do is, connect multiple OneDrive for Business accounts which are used for various departments and purposes and run a Batch or PowerShell Script to make a copy of all the files or to move them to a local backup location. We are aware of OneDrive for Business doing a backup for us yet we still want to be super cautious.

So the first problem we have is the following. I connect to my personal OneDrive for Business which is currently set to in account, mount as network drive Z:, No automatic mount, Use background uploading, Writable drive, no Proxy Settings and the Remote Path goes to “/My Drive/NetDrive Test”.

That’s about the settings. Now when I connect and open CMD or PowerShell I run “dir Z:”. It will list me everything inside and I see my 20-30 test files. Now when I run CMD or PowerShell as admin, I run “dir Z:” again and nothing will show up except for the error message:

“The system cannot find the path specified.”

dir : Cannot find drive. A drive with the name ‘Z’ does not exist.
At line:1 char:1
+dir Z:
+ CategoryInfo : ObjectNotFound: (Z:String) [Get-ChildItem], DriveNotFoundException
+ FullyQualifiedErrorId : DriveNotFound,Microsoft.PowerShell.Commands.GetChildItemCommand

Because of this it is impossible to properly use NetDrive the way we need it to work. What I have tried so far is to enable Linked Connections via Registry as my colleague said that it might solve the issue alltogether yet I still cannot connect to the Drive when using CMD or PowerShell as Admin.

Of course starting NetDrive as Admin and connecting the Drive doesn’t make a difference. It’s just that now the admin CMD & PowerShell can see the drive yet I can’t see it in the File Explorer.

I also tried setting the Drive to “In Device” but that doesn’t make any difference. I even tried using a second domain user account, just to see if the drive would show up when it’s mounted as “In device”.
Spoiler: It doesn’t.

Does anyone have an idea if this is linked to a bug or if we should use the Personal Plan instead of the Team Plan. It would also be good to know if I could request another trial period in case we can’t find a working solution within the trial period.

The current NetDrive Version: 3.15.450
Windows 10 21H2 (OS build: 19044.1586)


Thank you for using NetDrive.

I think you can solve the issue with below version.

A mounted drive is shown only the no-elevated session of windows account who mount the drive in Team Plan. The drive is not visible to the other users.

On the other hand, below version has a option “As a global drive” in Team Plan.

If you can turn the option on, the elevated user(administrator’s right) and the no-elevated user(normal right) can use the drive. But the other users of the Windows PC can use the drive too.


1 Like

Thank you for the updated version. Now it works to access the drive with the admin CMD and PowerShell. We will continue our testing and see how it goes. :wink:

Best regards

1 Like

Don’t hesitate to contact us.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.