NetDrive3 will not install. Failed to install vcredist14_x64.exe


I’m trying to install the latest version of NetDrive3 on Windows 10.

Netdrive2 works perfectly tho may I add.

I run the installer as administrator, and get the error.

Failed to install vcredist14_x64.exe.

Kind Regards


‘vcredist14_x64.exe’ is ‘Microsoft Visual C++ 2015 Redistributable (x64)’.

It could conflict with other software installed.

Please check installed components:

  1. Open ‘Programs and Features’
    You could open ‘Programs and Features’ by clicking Windows ‘Start’ Button and type ‘appwiz.cpl’.
  2. Search for items in the list that its title is starting ‘Microsoft Visual C++’.
  3. Take screen shot that contains those ‘Name’ and ‘Version’ informations.

Please attach the screen shot for further investigation.


Screenshot attached as requested.

Kind Regards

For temporary solution,
you could uninstall ‘Microsoft C++ 2017 Redistributable’ and install NetDrive3.
After that, you could install ‘Microsoft C++ 2017 Redistributable’ again.

You could do the solution by following steps:

  1. Click ‘Microsoft Visual C++ 2017 Redistributable (x64)’ and ‘Uninstall’ it.
    (You could uninstall it by double click it)

  2. Click ‘Microsoft Visual C++ 2017 Redistributable (x86)’ and ‘Uninstall’ it.
    (You could uninstall it by double click it)

  3. Install ‘NetDrive3’

  4. Install recent ‘Microsoft Visual C++ 2017 Redistributable (x64)’ and ‘Microsoft Visual C++ 2017 Redistributable (x86)’
    We uploaded recent install setups on
    And you could get install setups by yourself from Microsoft download page

For permanent solution, we need more time to solve it.


Thank you.

I have followed your instructions, and it has now installed successfully.

However, when launching NetDrive3, all that happens is the splash displays and then I get a error Bdrive NetDrive.exe is not responding.


I have upgraded to the latest version of NetDrive3 and am getting little further, now I cannot login.
I enter user and password and nothing happens.

Do you create any log files we could look at?

Just my 2 cents (not official netdrive support staff), uninstall nd3, reboot, reinstall, reboot. Try again. (if you haven’t already tried this)

I have the same problem on Windows 7 Enterprise with NetDrive 3.1.234. I have not tried installing on Windows 10 yet. Microsoft Visual C++ 2013 Redistributable (x86) - 12.0.30501 is installed along with other MSVS Redist packages.


  1. Check your system type, x64 / x86.

Did you install it according to the System based type.

  1. Enter the name of the program in the search box on the taskbar, press and hold (or right-click) the search result, and then select Open file location.

Or u just right click at the Desktop shortcut then click properties.

Go to the compatibility tab

run the troubleshooter

for netdrive3 the most compatible windows is windows 8.

run this program as administrator.

if this doesnt solve your issues.

3.You may use virtual machine.

4.Or Debug it using Visual Studio.

Ref Links -