Mac version doesn't work with High Sierra (10.13)

Got an error that the FUSE engine used by BDrive is too old.

There is a version mismatch in the installer package too which may be responsible for the problem you’re having.
Does your installed copy show as version 3.1.0, and advise there is an update available to 3.1.10?

Yes it did. Thanks

NetDrive 3 for Mac is under beta and it’s not working on High Sierra as noted on the download page. We need to update some packages for High Sierra.

And please ignore the update notice, too.

I didn’t see a download page, it was showing in my subscriptions page and that’s where I got it from.

v 3.4.201 for MacOS is working fine with 10.13.3