File permission with sftp, automatically switched to 644


I am trying to use Netdrive, but have an annoying problem:

When I edit a file like a libreoffice or word document, the permission of the file before editing is 660, the same as the folder containing the file. When I save the edited file, it automatically become with 644 permission. This happens when using Netdrive to acces sfpt from windows on a linux server.

This problem is really something that would make me try to find another software.

I found a previous topic with this problem but without any solution proposed.

Could you tell me if there is a way to make this right?

Thank you.



Thank you for using NetDrive.

I think the file you edited is a newly created file and renamed to a original file file.

You can set a permission for a new file and folder.

Press a “OPTIONS” button.

Then, you can see the option for the permissions.



Thank you, it works perfectly.


Don’t hesitate to contact us if you have any question.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.